#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?<!-)attorney(?!-)\b"
Local $sString = "attorney " & @CRLF & _
"attorney cat" & @CRLF & _
"construction-law " & @CRLF & _
"assistant-attorney " & @CRLF & _
"assistant attorney" & @CRLF & _
"attorneys and fakewordwithattorneyinit" & @CRLF & _
"My assistant-attorney wil see you now" & @CRLF & _
"The attorney-general was her" & @CRLF & _
"my attorney will be calling you"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")