$re = '/\b(?<!-)attorney(?!-)\b/m';
$str = 'attorney
attorney cat
construction-law
assistant-attorney
assistant attorney
attorneys and fakewordwithattorneyinit
My assistant-attorney wil see you now
The attorney-general was her
my attorney will be calling you';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);