re = /(?P<first1>\w+)[ ](?P<last1>\w+)|(?P<last2>\w+),[ ](?P<first2>\w+)/m
str = '"first_name last_name" or "last_name, first_name"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end