#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(compare it to )(([A-Z][a-zA-Z0-9]+)\s?([A-Z][a-zA-Z0-9]+)?\s?([A-Z][a-zA-Z0-9]+)?)"
Local $sString = "Overall Jeep is good for off-road and if we compare it to Mahindra Thar both are good vehicles but a Jeep is an expensive machine and Thar is also good in terms of driving. And if u have an expensive budget then I recommend going to Jeep Wrangler it's the best off-roading vehicle." & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"//compare it to ([A-Z][a-z]+ ){2}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")