import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(compare it to )(([A-Z][a-zA-Z0-9]+)\\s?([A-Z][a-zA-Z0-9]+)?\\s?([A-Z][a-zA-Z0-9]+)?)";
final String string = "Overall Jeep is good for off-road and if we compare it to Mahindra Thar both are good vehicles but a Jeep is an expensive machine and Thar is also good in terms of driving. And if u have an expensive budget then I recommend going to Jeep Wrangler it's the best off-roading vehicle.\n\n"
+ " \n"
+ "//compare it to ([A-Z][a-z]+ ){2}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}