const regex = /(compare it to )(([A-Z][a-zA-Z0-9]+)\s?([A-Z][a-zA-Z0-9]+)?\s?([A-Z][a-zA-Z0-9]+)?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(compare it to )(([A-Z][a-zA-Z0-9]+)\\s?([A-Z][a-zA-Z0-9]+)?\\s?([A-Z][a-zA-Z0-9]+)?)', 'gm')
const str = `Overall Jeep is good for off-road and if we compare it to Mahindra Thar both are good vehicles but a Jeep is an expensive machine and Thar is also good in terms of driving. And if u have an expensive budget then I recommend going to Jeep Wrangler it's the best off-roading vehicle.
//compare it to ([A-Z][a-z]+ ){2}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}