use strict;
my $str = 'Overall Jeep is good for off-road and if we compare it to Mahindra Thar both are good vehicles but a Jeep is an expensive machine and Thar is also good in terms of driving. And if u have an expensive budget then I recommend going to Jeep Wrangler it\'s the best off-roading vehicle.
//compare it to ([A-Z][a-z]+ ){2}';
my $regex = qr/(compare it to )(([A-Z][a-zA-Z0-9]+)\s?([A-Z][a-zA-Z0-9]+)?\s?([A-Z][a-zA-Z0-9]+)?)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}