re = /(compare it to )(([A-Z][a-zA-Z0-9]+)\s?([A-Z][a-zA-Z0-9]+)?\s?([A-Z][a-zA-Z0-9]+)?)/m
str = 'Overall Jeep is good for off-road and if we compare it to Mahindra Thar both are good vehicles but a Jeep is an expensive machine and Thar is also good in terms of driving. And if u have an expensive budget then I recommend going to Jeep Wrangler it\'s the best off-roading vehicle.
//compare it to ([A-Z][a-z]+ ){2}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end