$re = '/\[(.[0-9,]+)\]/';
$str = '[,][123,1][,][456,2][,][789,3][,][,][,][,][,][,][,][,]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);