package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z0-9._%+-]+@[a-z0-9.-]+?(?:\.com|\.org|\.co\.uk|\.org\.uk)$`)
var str = `sdhdhh@gmail.com
sdhdhh@gmail.co.uk
sdhdhh@gmail.org
sdhdhh@gmail.org.uk`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}