import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9._%+-]+@[a-z0-9.-]+?(?:\\.com|\\.org|\\.co\\.uk|\\.org\\.uk)$";
final String string = "sdhdhh@gmail.com\n"
+ "sdhdhh@gmail.co.uk\n"
+ "sdhdhh@gmail.org\n"
+ "sdhdhh@gmail.org.uk";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}