package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\S(?:\s*\S){6}|(?:\S\s*){,6}$`)
var str = `the quick brown fox jumps over the lazy doggo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}