# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*feat.*?)(\s*\(?feat.*\)\s*)(\.[^\.]+)$/$1$3/gm;t' <<< "Artist - Song (feat. OtherArtist) (feat. OtherArtist).mp4
Artist - Song (feat. OtherArtist) (Radio Edit) (feat. OtherArtist).mp4"