re = /"([^"]*\bsearchword\b[^"]*)"|'([^']*\bsearchword\b[^']*)'|"[^"]*"|'[^']*'/m
str = 'This "searchword1". searchword. "searchword"
This \'searchword2\'. searchword. "searchword"
This \'searchword 2\'. searchword. "Hello, searchword!"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end