// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"([^"]*\bsearchword\b[^"]*)"|'([^']*\bsearchword\b[^']*)'|"[^"]*"|'[^']*'"#).unwrap();
let string = "This \"searchword1\". searchword. \"searchword\"
This 'searchword2'. searchword. \"searchword\"
This 'searchword 2'. searchword. \"Hello, searchword!\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}