import Foundation
let pattern = ##"^(?:(?!^\s|[ \-']{2}|[\d\r\n\t\f\v!"#$%&()*+,\.\/:;<=>?@[\\\]^_`{|}~€‚ƒ„…†‡ˆ‰‹‘’“”•–—˜™›¡¢£¤¥¦§¨©ª«¬®¯°±²³´¶·¸¹º»¼½¾¿×÷№′″ⁿ⁺⁰‱₁₂₃₄]|\s$).){1,50}$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Regex matches: from 1 to 50 international letters separated by single delimiter ( -')
Regex rejects: empty prefix/suffix, consecutive delimiters ( -'), digits, new line, tab, limited list of extended ASCII characters
Jo Nesbø
Pedro Almodóvar
بيدرو ألمودوبار
Sofija Jogailaitė
Akira Kurosawa
Куросава Акіра
Куросава Акира
黒澤明
黑澤明
আকিৰা কুৰোছাৱা
Tyue' Tgshh
CxCx5C5C
AKIRA KUROSAWA
Akir@ Kursawa
Stev3 Smith
STeve Smith
Steve SMith
Steve Sm1th
Steve G. Smith
d'Are to Beaware
Hyoung Kyoung Wu
Mike O'Neal
Steve Johnson-Smith
Jozef-Schmozev Hiemdel
O Henry Smith
Mathais d'Arras
Martin Luther King Jr
Downtown-James Brown
Darren McCarty
An Ni
O. Henry McCarty
George De FunkMaster
Kurtis B-Ball
Ahmad el Jeffe
John Smith
'John Smith
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)