#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?P<a>[0-9]{1,3})-)?((?P<b>[0-9]{1,3}):)?(?P<cde>(?P<c>[0-9A-F]{1,3}).(?P<d>[0-9A-F]{1,3})(.(?P<e>[0-9A-F]{1,3}))?)([\*\&](?P<f>[0-9A-F]{1,3}))?\((?P<value>[^*^\)]*)(([\*])(?P<unit>\w*))?\)$"
Local $sString = "0-1:F.F.0*255(000000000000000)" & @CRLF & _
"0-1:F.F.2*255(000000000111100)" & @CRLF & _
"0-1:0.0.0*255(1ZPA0020280814)" & @CRLF & _
"1-0:C.1.0*255(0020280814)" & @CRLF & _
"1-0:0.0.2*255(4U110017012)" & @CRLF & _
"1-0:0.0.3*255(00000000)" & @CRLF & _
"1-0:0.9.1*255(22:38:32)" & @CRLF & _
"1-0:0.9.2*255(23-12-28)" & @CRLF & _
"1-0:0.2.0*255(05 r01)" & @CRLF & _
"1-0:0.1.2*01(231201000000)" & @CRLF & _
"1-0:0.1.2*02(231101000000)" & @CRLF & _
"1-0:0.1.2*03(231001000000)" & @CRLF & _
"1-0:0.1.2&04(230927075308)" & @CRLF & _
"1-0:1.8.0*255(000003.6382*kWh)" & @CRLF & _
"1-0:1.8.0*254(000003.6382*kWh)" & @CRLF & _
"1-0:1.8.0*01(000003.6382*kWh)" & @CRLF & _
"1-0:1.8.0*02(000003.6382*kWh)" & @CRLF & _
"1-0:1.8.0*03(000003.6382*kWh)" & @CRLF & _
"1-0:1.8.0&04(000000.0000*kWh)" & @CRLF & _
"1-0:1.8.1*255(000003.6382*kWh)" & @CRLF & _
"1-0:1.8.1*254(000003.6382*kWh)" & @CRLF & _
"1-0:1.8.1*01(000003.6382*kWh)" & @CRLF & _
"1-0:1.8.1*02(000003.6382*kWh)" & @CRLF & _
"1-0:1.8.1*03(000003.6382*kWh)" & @CRLF & _
"1-0:1.8.1&04(000000.0000*kWh)" & @CRLF & _
"1-0:1.8.2*255(000000.0000*kWh)" & @CRLF & _
"1-0:1.8.2*254(000000.0000*kWh)" & @CRLF & _
"1-0:1.8.2*01(000000.0000*kWh)" & @CRLF & _
"1-0:1.8.2*02(000000.0000*kWh)" & @CRLF & _
"1-0:1.8.2*03(000000.0000*kWh)" & @CRLF & _
"1-0:1.8.2&04(000000.0000*kWh)" & @CRLF & _
"1-0:2.8.0*255(000000.6248*kWh)" & @CRLF & _
"1-0:2.8.0*254(000000.6248*kWh)" & @CRLF & _
"1-0:2.8.0*01(000000.6248*kWh)" & @CRLF & _
"1-0:2.8.0*02(000000.6248*kWh)" & @CRLF & _
"1-0:2.8.0*03(000000.6248*kWh)" & @CRLF & _
"1-0:2.8.0&04(000000.0000*kWh)" & @CRLF & _
"1-0:2.8.1*255(000000.6248*kWh)" & @CRLF & _
"1-0:2.8.1*254(000000.6248*kWh)" & @CRLF & _
"1-0:2.8.1*01(000000.6248*kWh)" & @CRLF & _
"1-0:2.8.1*02(000000.6248*kWh)" & @CRLF & _
"1-0:2.8.1*03(000000.6248*kWh)" & @CRLF & _
"1-0:2.8.1&04(000000.0000*kWh)" & @CRLF & _
"1-0:2.8.2*255(000000.0000*kWh)" & @CRLF & _
"1-0:2.8.2*254(000000.0000*kWh)" & @CRLF & _
"1-0:2.8.2*01(000000.0000*kWh)" & @CRLF & _
"1-0:2.8.2*02(000000.0000*kWh)" & @CRLF & _
"1-0:2.8.2*03(000000.0000*kWh)" & @CRLF & _
"1-0:2.8.2&04(000000.0000*kWh)" & @CRLF & _
"1-0:0.2.2*255(00750101)" & @CRLF & _
"1-0:C.15.0*255(23-04-07)" & @CRLF & _
"1-0:0.2.6*255(intErn)" & @CRLF & _
"1-0:C.6.0*255(00 00:07:33)" & @CRLF & _
"1-0:C.14.0*255(T2)" & @CRLF & _
"1-0:C.9.0*255(+27.0*C)" & @CRLF & _
"1-0:C.6.3*255(3.66*V)" & @CRLF & _
"1-0:C.1.6*255(98FC51FF)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")