const regex = /\s*([^\w\s])\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*([^\\w\\s])\\s*', 'gm')
const str = `Some - text +=@!#\$#\$^%* here . `;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);