$re = '/\b(\w+)\s*-\s*(\w+)\b/m';
$str = 'I\'m going to be out of the office from 2-4pm or I\'m out of the office from 10am-noon tomorrow';
$subst = "\1 to \2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;