$re = '/(?: \/ |\A)((?:(?! \/ )[^:])+):/';
$str = 'Lorem: 8 FB / Ipsum-/Dolor: Some Text / Dolor: Some text with (brackets) / Sit amet.:
Some Text with/slash / foobar / Last one: 36 foos';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);