#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([^"]+"[^"]+")([^"]+)"([^"]+)""
Local $sString = "Production App "Old": Service Name: ".ProdApp - Slave1""
Local $sSubst = "$1$2$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)