use strict;
my $str = 'Production App "Old": Service Name: ".ProdApp - Slave1"';
my $regex = qr/([^"]+"[^"]+")([^"]+)"([^"]+)"/mp;
my $subst = '$1$2$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";