re = /([^"]+"[^"]+")([^"]+)"([^"]+)"/m
str = 'Production App "Old": Service Name: ".ProdApp - Slave1"'
subst = '$1$2$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result