const regex = /\s+\d+\/\d+\w*g$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+\\d+\\\/\\d+\\w*g$', 'gm')
const str = `Cashew Alm Classic 6/200g
Cashew Buttery Sprd 8/227g
Chives&Garlic 6/98g`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);