package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\s\S].*?)([.*=,])?`)
var str = `John is happy. He owns 3*4=12, apples`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}