$re = '/\$this->\w++(?!\()/m';
$str = '$this->willMatch but $this->willNot()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);