re = /(?<=\()\d\d-?\d\d.*?(?=\))/
str = 'random text here (00-04) more random text
lame text (junk data) more text (08-12)
random text (2008)
random text (2005) junk text (junk)
nothing important (13-15) not important (not important)
nothing important (13-15 text) not important (not important)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end