using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\=(?=([^\""']*[\""'][^\""']*[\""'])*[^\""']*$)";
string input = @"a=""one"", b=10, c=[""1"",2,3], d=""a=1"", e=""b='two'"", f='q=""hello""', g={""a"":1}, h = x + ""hello"", i = {q:[1,'c']}, h=""[1,2,3]"", j = '""hello, there""', k = a~b + c
https://stackabuse.com/regex-splitting-by-character-unless-in-quotes/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}