import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\=(?=([^\\\"']*[\\\"'][^\\\"']*[\\\"'])*[^\\\"']*$)";
final String string = "a=\"one\", b=10, c=[\"1\",2,3], d=\"a=1\", e=\"b='two'\", f='q=\"hello\"', g={\"a\":1}, h = x + \"hello\", i = {q:[1,'c']}, h=\"[1,2,3]\", j = '\"hello, there\"', k = a~b + c\n\n\n"
+ "https://stackabuse.com/regex-splitting-by-character-unless-in-quotes/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}