#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^0-3][0-9]{7}"
Local $sString = "91234567" & @CRLF & _
"81234567" & @CRLF & _
"71234567" & @CRLF & _
"61234567" & @CRLF & _
"51234567" & @CRLF & _
"41234567" & @CRLF & _
"31234567" & @CRLF & _
"21234567" & @CRLF & _
"11234567" & @CRLF & _
"01234567"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")