re = /^[^0-3][0-9]{7}/m
str = '91234567
81234567
71234567
61234567
51234567
41234567
31234567
21234567
11234567
01234567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end