package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{1,12}(?:\.\d{1,2})?$`)
var str = `100000000000
000000000000
999999999999
999999999999.a
999999999999.1
999999999999.22
2999999999999.22
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}