# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\G((?:.\D)*.)\d/$1*/g;t' <<< "a1b2cde3~g45hi6
Match any char with a non digit ( This is to ensure that the /G carries on to the next pair)
store any char in \1
Match any digit"