import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\G((?:.\\D)*.)\\d";
final String string = "a1b2cde3~g45hi6\n\n"
+ "Match any char with a non digit ( This is to ensure that the /G carries on to the next pair)\n"
+ "store any char in \\1\n"
+ "Match any digit";
final String subst = "$1*";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}