use strict;
my $str = 'a1b2cde3~g45hi6
Match any char with a non digit ( This is to ensure that the /G carries on to the next pair)
store any char in \\1
Match any digit';
my $regex = qr/\G((?:.\D)*.)\d/p;
my $subst = '$1*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";