# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\G((?:.\D)*.)\d"
test_str = ("a1b2cde3~g45hi6\n\n"
"Match any char with a non digit ( This is to ensure that the /G carries on to the next pair)\n"
"store any char in \\1\n"
"Match any digit")
subst = "$1*"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.