#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*<!\[CDATA\[00000:((?:\s|\S)*?)\]\]>.*"
Local $sString = "String srcMsg="<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n<root><resultCode>00000</resultCode><resultDesc>" & @CRLF & _
"<![CDATA[00000:<ResponseClass Name=\"Response\">\n <ResponseSubClass Name=\"attributesResponse\">\n" & @CRLF & _
" <ITEM>0</ITEM>\n </ResponseSubClass>\n</ResponseClass>]]></resultDesc></root>";" & @CRLF & _
"//The right code " & @CRLF & _
"java.util.regex.Pattern pP0 = java.util.regex.Pattern.compile(".*<!\\[CDATA\\[00000:((.|\n)*)\\]\\]>.*"); " & @CRLF & _
"//wrong code1 " & @CRLF & _
"//java.util.regex.Pattern pP0 = java.util.regex.Pattern.compile(".*<!\\[CDATA\\[00000:(\\s|\\S)*\\]\\]>.*");" & @CRLF & _
"//wrong code2 " & @CRLF & _
"//java.util.regex.Pattern pP0 = java.util.regex.Pattern.compile(".*<!\\[CDATA\\[00000:[\\w|\\W]*\\]\\]>.*");" & @CRLF & _
"java" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<![CDATA[00000: asdfasdf" & @CRLF & _
"sssdgasgf" & @CRLF & _
"" & @CRLF & _
"asfgas" & @CRLF & _
"]]>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")