using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*<!\[CDATA\[00000:((?:\s|\S)*?)\]\]>.*";
string input = @"String srcMsg=""<?xml version=\""1.0\"" encoding=\""UTF-8\""?>\n<root><resultCode>00000</resultCode><resultDesc>
<![CDATA[00000:<ResponseClass Name=\""Response\"">\n <ResponseSubClass Name=\""attributesResponse\"">\n
<ITEM>0</ITEM>\n </ResponseSubClass>\n</ResponseClass>]]></resultDesc></root>"";
//The right code
java.util.regex.Pattern pP0 = java.util.regex.Pattern.compile("".*<!\\[CDATA\\[00000:((.|\n)*)\\]\\]>.*"");
//wrong code1
//java.util.regex.Pattern pP0 = java.util.regex.Pattern.compile("".*<!\\[CDATA\\[00000:(\\s|\\S)*\\]\\]>.*"");
//wrong code2
//java.util.regex.Pattern pP0 = java.util.regex.Pattern.compile("".*<!\\[CDATA\\[00000:[\\w|\\W]*\\]\\]>.*"");
java
<![CDATA[00000: asdfasdf
sssdgasgf
asfgas
]]>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}