use strict;
my $str = 'String srcMsg="<?xml version=\\"1.0\\" encoding=\\"UTF-8\\"?>\\n<root><resultCode>00000</resultCode><resultDesc>
<![CDATA[00000:<ResponseClass Name=\\"Response\\">\\n <ResponseSubClass Name=\\"attributesResponse\\">\\n
<ITEM>0</ITEM>\\n </ResponseSubClass>\\n</ResponseClass>]]></resultDesc></root>";
//The right code
java.util.regex.Pattern pP0 = java.util.regex.Pattern.compile(".*<!\\\\[CDATA\\\\[00000:((.|\\n)*)\\\\]\\\\]>.*");
//wrong code1
//java.util.regex.Pattern pP0 = java.util.regex.Pattern.compile(".*<!\\\\[CDATA\\\\[00000:(\\\\s|\\\\S)*\\\\]\\\\]>.*");
//wrong code2
//java.util.regex.Pattern pP0 = java.util.regex.Pattern.compile(".*<!\\\\[CDATA\\\\[00000:[\\\\w|\\\\W]*\\\\]\\\\]>.*");
java
<![CDATA[00000: asdfasdf
sssdgasgf
asfgas
]]>';
my $regex = qr/.*<!\[CDATA\[00000:((?:\s|\S)*?)\]\]>.*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}