#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\w{1,2}-\d{1,4})(\w)\/(\w)\/(\w)"
Local $sString = "D-1150A/B/C" & @CRLF & _
""
Local $sSubst = "\1\2\n\1\3\n\1\4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)