using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w{1,2}-\d{1,4})(\w)\/(\w)\/(\w)";
string substitution = @"\1\2\n\1\3\n\1\4";
string input = @"D-1150A/B/C
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}