import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(-scaled|[_-]\\d+x\\d+)|@[2-6]\\x(?=\\.[a-z]{3,4}$)|\\.[a-z]{3,4}.webp";
final String string = "skip-IMG_7484-scaled.jpg\n"
+ "skip-IMG_7484.jpeg.webp\n"
+ "skip-IMG_7484.jpg.webp\n"
+ "skip-filename_500x383dddd.jpeg\n"
+ "skip-filename_500x383.jpeg\n"
+ "skip-filename-500x383.jpeg\n"
+ "skip-filename-500x383.jpg\n"
+ "skip-filename-500x383@2xddddd.jpg\n"
+ "skip-filename-500x383@2x.jpg\n"
+ "skip-filename-100x100@2x.jpg\n"
+ "skip-filename-1000x1000@3x.jpg\n"
+ "skip-filename-40x40@4x.jpg\n"
+ "keep-filename@2x copy.jpg\n"
+ "keep-filename@2x.jpg\n"
+ "keep-filename@3x.jpg\n"
+ "keep-filename@4x.jpg\n"
+ "keep-IMG_7484-normal-webp.webp\n"
+ "keep-IMG_7484-not-dot-jpg.webp\n"
+ "keep-IMG_7484.jpg\n"
+ "keep-f5229.jpg\n"
+ "keep-f5229as'ad\"an.jpg";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}