import re
regex = re.compile(r"([a-zA-Z_]\w+|[a-zA-Z]\w*|\[\s*[a-zA-Z_]\w+\s*\]|\[\s*[a-zA-Z]\w*\s*\])\s*\[\s*['\"]([a-zA-Z_]\w+|[a-zA-Z]\w*)['\"]\s*\]", flags=re.MULTILINE)
test_str = ("a['b'][c]\n"
"a['1']\n"
"a['b1']\n"
"a[1]\n"
"a['_'] --I am pretty sure this is bad to match\n"
"a[\"__\"] --idk if this is bad to match\n"
"a[\"_ _\"] \n"
"a[\"up\"]\n"
"a[\"up \"]\n"
"a['b']['c'] --notice how this doesn't match the first quote with the last one\n"
"a[\"workwork\"]\n"
"_adf [ 'test' ] --even when imporoperlly formated this is valid lua\n"
"a.[b] [\"yup\"] --this case preserves the [b] and will append .yup after it\n"
"a[\"a.basdf\"]\n"
"\"adlfkajsd.dklajdlakj\"")
subst = "$1.$2"
result = regex.sub(subst, test_str)
if result:
print(result)