\[the literal [ (9110 / 1338 / 5B16)
Non-Capturing Group(?:https?|ftp) httpthe literal text http (case insensitive) s?optionally matches the literal s (11510 / 1638 / 7316) (case insensitive)
ftpthe literal text ftp (case insensitive) :the literal : (5810 / 728 / 3A16)
\/the literal / (4710 / 578 / 2F16)
\/the literal / (4710 / 578 / 2F16)
Negated Character Class[^\]\[]+ +matches at least one character outside the set below:
\]the literal ] (9310 / 1358 / 5D16)
\[the literal [ (9110 / 1338 / 5B16)
\]the literal ] (9310 / 1358 / 5D16)
\(the literal ( (4010 / 508 / 2816)
Negated Character Class[^()]* *matches any number of characters outside the set below:
(the literal ( (4010 / 508 / 2816)
)the literal ) (4110 / 518 / 2916)
\)the literal ) (4110 / 518 / 2916)