#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*)(Afronding)([0-9\"\.\s:]*)(,\n)"
Local $sString = "{" & @CRLF & _
" "ImsManifestIdentifier": "MMANIFEST-2b0b0b9e-6a3c-4af6-ac18-903355ffab58"," & @CRLF & _
" "PackageGuid": "ab8b5d84-b165-4806-a5fc-58d00ce2a195"," & @CRLF & _
" "PackageVersie": 223296366," & @CRLF & _
" "ToetsGuid": "09f5836d-285a-4970-ad93-fb9610201e15"," & @CRLF & _
" "ToetsVersie": 10001," & @CRLF & _
" "RuweScore": "0"," & @CRLF & _
" "Vaardigheid": "0"," & @CRLF & _
" "Afronding": "1"," & @CRLF & _
" "SchoolTypes": {" & @CRLF & _
" "VOVMBO": "1"," & @CRLF & _
" "MBO2": "1"," & @CRLF & _
" "MBO3": "1"" & @CRLF & _
" }" & @CRLF & _
" }, {" & @CRLF & _
" "ImsManifestIdentifier": "MMANIFEST-2b0b0b9e-6a3c-4af6-ac18-903355ffab58"," & @CRLF & _
" "PackageGuid": "ab8b5d84-b165-4806-a5fc-58d00ce2a195"," & @CRLF & _
" "PackageVersie": 223296366," & @CRLF & _
" "ToetsGuid": "09f5836d-285a-4970-ad93-fb9610201e15"," & @CRLF & _
" "ToetsVersie": 10001," & @CRLF & _
" "RuweScore": "1"," & @CRLF & _
" "Vaardigheid": "14,0"," & @CRLF & _
" "Afronding": "1"," & @CRLF & _
" "SchoolTypes": {" & @CRLF & _
" "VOVMBO": "1,1"," & @CRLF & _
" "MBO2": "1,1"," & @CRLF & _
" "MBO3": "1"" & @CRLF & _
" }" & @CRLF & _
" }, {" & @CRLF & _
" "ImsManifestIdentifier": "MMANIFEST-2b0b0b9e-6a3c-4af6-ac18-903355ffab58"," & @CRLF & _
" "PackageGuid": "ab8b5d84-b165-4806-a5fc-58d00ce2a195"," & @CRLF & _
" "PackageVersie": 223296366," & @CRLF & _
" "ToetsGuid": "09f5836d-285a-4970-ad93-fb9610201e15"," & @CRLF & _
" "ToetsVersie": 10001," & @CRLF & _
" "RuweScore": "2"," & @CRLF & _
" "Vaardigheid": "23"," & @CRLF & _
" "Afronding": "1"," & @CRLF & _
" "SchoolTypes": {" & @CRLF & _
" "VOVMBO": "2,5"," & @CRLF & _
" "MBO2": "2,5"," & @CRLF & _
" "MBO3": "1,5"" & @CRLF & _
" }" & @CRLF & _
" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")