re = /^.+_pn\b.+$/m
str = 'Adam Nyquist - Never Gonna Stop (Tom Chubb Remix)_pn.mp3
Adam Nyquist - Never Gonna Stop (Tom Chubb Remix)_pblah.mp3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end