const regex = /.*:(?s).*?(?=\bAnd\b|$)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*:(?s).*?(?=\\bAnd\\b|$)', '')
const str = `And we validate that the following occurrences for event 123456 and source PLAYER are saved in Database:
| PLAYER | GAME |
| 1 | FOOTBALL |
And we validate that the following messages for event 123456 and source PLAYER are sent in Other Database:`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}