#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([. ])(com|ltd|llc|corp|stores)"
Local $sString = "Amazon" & @CRLF & _
"Amazon.com" & @CRLF & _
"Amazon.llc" & @CRLF & _
"Amazon.ltd" & @CRLF & _
"Amazon corp" & @CRLF & _
"Amazon stores"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")