using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([. ])(com|ltd|llc|corp|stores)";
string input = @"Amazon
Amazon.com
Amazon.llc
Amazon.ltd
Amazon corp
Amazon stores";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}