use strict;
my $str = '"Supermajority Vote for State Taxes or fees" or taxes or "ssd or ffF"
"Supermajority Vote for State Taxes or fees" | taxes | "ssd or ffF"
';
my $regex = qr/\bor\b(?=([^\"]|\"[^\"]+\")+$)/p;
my $subst = '|';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";